Page Header Image

Aziza Forum pages return 404 on preview

Home Forums Aziza WordPress theme Aziza Forum pages return 404 on preview

Tagged: 

Viewing 13 reply threads
  • Author
    Posts
    • #72855
      Terry ThomasTerry Thomas
      Member

      I’m sure I’m doing something wrong here, but the Forum section of my Aziza theme back end is going to my 404 page when I try to preview the forum. Additionally, when I save the page as a draft, it publishes it anyway. Any reason for this?

      WP v4.2.2
      Azia Child Theme version says v1.0. I’m sure this is old, how do I update?

      Sincerely,
      Terry

    • #72858
      Terry ThomasTerry Thomas
      Member

      Update: Installed 1.4 and I’m still having this problem. I’m sure it’s something I’m not understanding, but a walkthrough would help tremendously.

      Sincerely,
      Terry

    • #72863

      Hi Terry,

      Try to save the permalinks, we have see this sometimes and saving the permalinks always fix it.

      Saving as draft/publishes it anyway is new to me, it’s not theme related as it’s a wp core feature. But deactivate all plugins and try again, maybe it’s a plugin acting weird.

      There is no update for the child theme as it’s not needed, so no worries there.

      Please share your findings
      Mike

    • #72916
      Terry ThomasTerry Thomas
      Member

      Mike,

      Thanks for the response, though I’m not sure what “save permalinks” means. I went to the permalinks page in my settings and clicked on “save changes”, but this does not fix the problem, nor does it make sense that it should.

      I’m not sure I can give you any other information about the automatic publishing issue, other than to say that when I click on “save as draft” it lists the forum as published (not as a draft), yet I only get a 404 when I attempt to view the page. When I’m initially editing the forum page and click on “preview” I also get the 404 page.

      If there are specific steps I need to take, please walk me through them.

      Sincerely,
      Terry

    • #72917
      Helen (staff)Helen (staff)
      Keymaster

      How to set up Permalinks

      Editing your WordPress Permalinks is good for SEO purposes. You can make the URL of your website more readable for your visitors. Tweaking your permalinks can also give you an advantage to search engines such as Google, Bing and Yahoo. This way your content can be easily found and indexed.

      For more information and details on how to customize your permalinks, please visit:

      http://codex.wordpress.org/Using_Permalinks

    • #72918
      Terry ThomasTerry Thomas
      Member

      Mike,

      Forgive me for not clearly communicating. I know how to set up permalinks, but my question was more in line with specifically what changes I will need to make to eliminate this problem.

      I have saved my permalinks, I have changed my permalinks, and I have saved them again. Without knowing the nature of the cause, I have no clue what changes I need to make to my permalinks. Nothing I’ve tried so far seems to have any effect on the problem. Forum pages are still returning a 404, and saving as draft (and even abandoning the page without saving for that matter) ends up publishing the forum.

      Is there anything else I can try?

      Sincerely,
      Terry

    • #72919

      Hi Terry,

      You don’t need to make changes to the permalinks, just select the option Post name and hit save. Here you can find a bit more info about this subject: https://bbpress.org/forums/topic/page-not-found-error/

      – Deactivate Aziza and activate a other one, just to see if you still have the 404 issue and to make sure it’s not a theme issue. ( don’t think so but you never…) It’s working on our website.

      – Deactivate all other plugins, to make sure it’s not a conflict with a plugin.
      – Check the ht-access file, maybe there is something weird.
      – You have the latest version of bbpress / aziza right?

      Still Nothing is working:

      – send me a url so I can have a quick look, maybe I see something if not we can investigate your installation for you. ( premium support needed)

      Hope this helps,
      Mike

    • #72921
      Terry ThomasTerry Thomas
      Member

      Mike,

      Thanks for staying with this.

      The permalink for the forum reads: http://tabletopplus.com/forums/forum/

      I activated another theme and still had the same problem, so it might not be a theme issue. I think I’m screwing something up somewhere.

      Deactivating plugins does not have any impact on the problem.

      I cannot find a file called ht-access in my file manager perhaps that’s the problem. I have lots of files that reference “/.htaccess” but no file of that name.

      I am running 1.4. Is that the latest?

      Sincerely,
      Terry H. Thomas

    • #72922

      Terry,

      Look by FTP if you have the htaccess file, depends of the setting if it’s set to hide.
      But not sure if thats the issue because I can see the forum list : http://tabletopplus.com/forums/

      Ahaaa you have used a wrong link: http://tabletopplus.com/forums/forum/

      It looks like there is no forum with a name forum.

      Create a new forum, add a post and go to menus and drag and drop the forum into a menu and see 🙂

    • #72923
      Terry ThomasTerry Thomas
      Member

      Mike,

      Thanks for sticking with me on this. I think we’re getting closer.

      I’m not sure I did this right, but I tried putting the forum into a menu. The link went into the menu, but still returned a 404 when I clicked on the link.

      I’m not sure what you meant by “add a post” since I cannot add a post to the page. The forum never materializes (404) so I can’t add a post.

      I agree that the problem is probably the permalink, but I’m not sure of the exact relationship between the funky permalink and the solution to the problem.

      Sincerely,
      Terry

    • #72924
      Terry ThomasTerry Thomas
      Member

      Mike,

      One more thing. The http://tabletopplus.com/forums/ page works. I can see the forum listed in the forum list. It just returns 404 when I go the forum itself.

      Terry

    • #72925
      Terry ThomasTerry Thomas
      Member

      Mike,

      GOT IT! The permalink in the Forums editor is not automatically populating. I think must have, at one time, deleted the default setting (something like %forum-name%, but I’m sure that’s not it). It’s actually blank in the permalinks section. Do you know how to set it so that it automatically populates with the forum name?

      I manually completed the permalink in the Forum editor and voila! It worked!

      Thanks for the discussion. I don’t think I would have found it this quickly if you hadn’t given me your feedback as a sounding board.

      Sincerely,
      Terry

    • #72926
      Terry ThomasTerry Thomas
      Member

      Mike,

      Hmmm… I looked at the permalinks section in settings and the forums section in settings, and there doesn’t appear to be a place to automate the permalink name like there is with posts and woocommerce product settings. Any answers there?

      Sincerely,
      Terry

    • #72928

      Thats fine because it will take the settings from: Common Settings

Viewing 13 reply threads
  • You must be logged in to reply to this topic.