Page Header Image

Issue with CRON job : error 403

Home Forums UM Switcher Issue with CRON job : error 403

This topic contains 10 replies, has 3 voices, and was last updated by Mike de Leeuw(staff) Mike de Leeuw(staff) 1 week ago.

  • Author
    Posts
  • #82786
    Maxelio42
    maxelio42
    Member

    Hello,
    I just purchased UM-Switcher, and can’t achieve to set the CRON job.
    My host provider is INFOMANIAK, which indeed has a CRON job planifier.
    I’ve set the job with the following URL (see attached image) : https://les-castors.fr/wp-admin/admin-ajax.php?action=umswticher_cronjob
    , which is the one you indicate in the plugin settings (see attached image). And, of course, I indicated my login/password to to give access to this PHP file.

    When I test the CRON job, the result is this error :

    Nom du cron : CRON UM Switcher
    Date : 30/06/2019 19:05:54
    Url : https://les-castors.fr/wp-admin/admin-ajax.php?action=umswticher_cronjob
    Resultat : OK
    Detail : 403
    Reponse : HTTP/1.1 403 Forbidden Date: Sun, 30 Jun 2019 17:05:52 GMT Server: Apache Content-Type: text/html; charset=utf-8
    Access forbidden!
    You don’t have permission to access the requested object. It is either read-protected or not readable by the server.

    Can you help please?
    Is this error linked to an error on the link?
    And, by the way, is it normal to have “umswticher_cronjob”, and not “umswitcher_cronjob”, for instance?

  • #82791
    Roy Pepito
    Roy Pepito
    Moderator

    Hi Maxelio,

    We’re checking on it.

    Can you please try to update your file permission in the FTP maybe it’s not re-writable.

    Regards

    Roy

  • #82793
    Maxelio42
    maxelio42
    Member

    Hi Roy,

    I checked my permissions on the directories and files, they are “Read/Write/Execute” everywhere, as you can see on the attached screen capture.

    Is this OK for you?

  • #82796
    Roy Pepito
    Roy Pepito
    Moderator

    Hi Maxelio,

    I’m still in the process of testing and checking the issue. I’ll make sure to update you as early as possible.

    I’ll keep you posted.

    Thanks,
    Roy

  • #82797
    Roy Pepito
    Roy Pepito
    Moderator

    Hi Maxelio,

    Kindly try to use the permission i attached “774”.

    I you try to run the path manually “https://les-castors.fr/wp-admin/admin-ajax.php?action=umswticher_cronjob” the script is being accessed without any errors.

    Looks like the issue here is in your wordpress setup and it could probably be on your security both server side on on wordpress.

    Here’s some other related issues about wordpress admin-ajax.php:

    https://stackoverflow.com/questions/44205211/wordpress-forbidden-you-dont-have-permission-to-access-wp-admin-admin-ajax-php

    Thanks,
    Roy

    Attachments:
  • #82799
    Roy Pepito
    Roy Pepito
    Moderator

    Hi Maxelio,

    Kindly try to use the permission i attached “774”.

    I you try to run the path manually “https://les-castors.fr/wp-admin/admin-ajax.php?action=umswticher_cronjob” the script is being accessed without any errors.

    Looks like the issue here is in your wordpress setup and it could probably be on your security both server side on on wordpress.

    Here’s some other related issues about wordpress admin-ajax.php:

    https://stackoverflow.com/questions/44205211/wordpress-forbidden-you-dont-have-permission-to-access-wp-admin-admin-ajax-php

    Thanks,
    Roy

    Attachments:
  • #82801
    Maxelio42
    maxelio42
    Member

    Hi Roy,

    I tried with 774 permission on the file, but no way, the issue is still here !

    What do you mean by “I you try to run the path manually “https://les-castors.fr/wp-admin/admin-ajax.php?action=umswticher_cronjob” the script is being accessed without any errors.” ?

    I entered this direct link in my navigator’s bar, the result is the same : 403 error.

    What can I can do in my WordPress setup to try to solve this issue?
    By the way, I have the plugin “Really Simple SSL” running, to have my site behind SSL protection. Could it be a part of the problem?

    For your information, I asked my hosting provider (Infomaniak) for help, I’m waiting for a response…

  • #82803
    Maxelio42
    maxelio42
    Member

    Hi Roy,

    The CRON issue was finally solved by my host provider (a problem with a “mod_security” rule, as it seems).

    Now let’s cope with the next problem : your plugin has a compatibility issue with another one, which is an add-on of the plugin WPforo forum, named “Advanced Attachments” (see this site : https://gvectors.com/product/wpforo-advanced-attachments/).

    This add-on display a dialog box allowing to upload, store in list and attach files in forum posts.

    Normally, the dialog box displays every file you’ve already uploaded in your list (see first attached image).

    Whenever your plugin is active, this dialog box turns blank (see second attahced image), and moreover it’s impossible to add a new file in it.

    Perhaps a problem with javascript files?
    How could you solve this?

    Thanks for your help!

  • #82810

    Hello maxelio42,

    Well if there is a conflict with UMS, please upload a screenshot with the notice/error that says it’s coming from UMS. Your screenshots don’t give me info about a conflict. Use for example Firefox firebug

  • #82811
    Maxelio42
    maxelio42
    Member

    Hello Roy,

    The developers of “Advanced Attachments” plugion just released an update, and the issue seems to be solved.

    Cheers!

  • #82817

    Thanks for the update, always good to hear.

You must be logged in to reply to this topic.